更新至gradle3.3.0后,variant.getJavaCompile()和variantOutput.getPackageApplication()警告的原因

WARNING: API ‘variant.getJavaCompile()’ is obsolete and has been replaced with ‘variant.getJavaCompileProvider()’.
It will be removed at the end of 2019.

WARNING: API ‘variantOutput.getPackageApplication()’ is obsolete and has been replaced with ‘variant.getPackageApplicationProvider()’.
It will be removed at the end of 2019.

前两天更新到Android Studio 3.3后,对应的gradle tools也更新到了3.3.
随之而来的就出现了上面的警告提示

上面的警告告诉我这些过时的Api将在2019年被移除。
出现这个警告的原因大概率是因为我们依赖的第三方插件使用了过时的API导致的。

我们暂时无需理会,等待依赖库更新即可。
如果强迫症看着实在难受,可暂时将根目录中build.gradle中的
classpath 'com.android.tools.build:gradle:3.3.0’
版本修改为以前的版本(如:3.2.1),就不会出现这个警告了。

在这里插入图片描述


如果你觉得本文对你有帮助,麻烦动动手指顶一下,算是对本文的一个认可,如果文中有什么错误的地方,还望指正,转载请注明转自喻志强的博客 ,谢谢!

©️2020 CSDN 皮肤主题: 书香水墨 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值